Technical FAQs

Ask a Question

ATV312 Solar drive is running good in DC supply form solar panel and not able to run at full speed in 3 phase AC generator supply?

The following additional information and description of fault were collected form customer to understand the problem,
The pump runs fine on Solar DC Bus but won't run at full speed of 50 Hz on generator supply. In morning the unit are running at 50 Hz on Solar and it continues running at full speed during peak sun light hours. When switching over to generator supply in evening, the generator supply is 390 VAC the DC Bus Voltage is 550VDC. When the drive is switched to generator supply, the VFD runs on Low Speed Set point 25 Hz only. The low set point are adjusted to 50 Hz and found the unit runs on 50Hz without any problem. It is mandatory to the customer to run the pump on solar and generator to supply enough water.

The drive has following parameter settings, which are found ok.  
- Sun - Low Speed -25
- Hi Speed - 50
- Internal PID ref 638.4 VDC
- MPP - PID prop gain 1
- PID int gain 1
- RPG2 4
- RIG2 4
- LP - LPA No
- UL- ULT 60
- LUL Auto
- SLUL - Done
- SRB - 0.3
- FUT- 2
- LITR 300
- ref- AIV1 -0%
- Int PID ref 638.4

After analyzing above parameter settings and observations, it is understood that "when the low speed set point are adjusted to 50 Hz the unit runs on 50Hz". It means the DC Bus supply is sufficient enough for driving the motor up to 50HZ in generator supply. But it is found that the drive did not get the speed reference when operating through generator supply. It is the reason for the drive running at minimum speed setting of 25HZ. 

To solve the problem, you can change the parameter setting as below.

1. PU (Photovoltaic Menu Only) - "0", with this setting you will be able to see more ATV312 parameter settings. 



2. Now you can assign the parameter FR1 to AI1 & RFC to FR1, which will enable the speed reference through AI1 (through potentiometer). The drive speed can be varried through AI1 input through potentiometer.




3. You can also assin preset speed setting PS2 to LI3 & SP2 to 50HZ. With this setting, the drive will run at 50HZ if LI3 is activated.





After changing the above parameter settings, you can give the reference through analog input 1 or you can give preset speed selecton command in LI3 for running the pump at full speed.
Was this helpful?
What can we do to improve the information ?